В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
maksim22771
maksim22771
05.05.2020 03:20 •  Информатика

Составить программу, которая проверяет является ли билет счастливым. в билете 6 цифр. 8 !

Показать ответ
Ответ:
Anastasiya922
Anastasiya922
21.08.2020 10:12
//PascalABC.NET
//Версия 3.3, сборка 1627
begin
var a:=ReadString();
write(a.SkipLast(3).Select(x->x.ToDigit()).Sum()=a.Skip(3).Select(x->x.ToDigit()).Sum());
end.
0,0(0 оценок)
Ответ:
akkusha1
akkusha1
21.08.2020 10:12
Var
a,sum1,sum2,i:longint;
begin
Readln(a);
for i:= 1 to 3 do
  begin
    sum1 := sum1 + a mod 10;
    a:= a div 10;
  end;
for i:= 1 to 3 do
  begin
    sum2 := sum2 + a mod 10;
    a:= a div 10;
  end;  
if (sum1 = sum2) then Writeln('YES')
  else Writeln('NO');
end.

Пример:
123321
YES
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота