В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
kisa1756
kisa1756
09.07.2021 16:06 •  Информатика

Задача на паскале. Батарея состоит из прямоугольных обогревательных секций. Все секции имеют одинаковый размер и одинаковую мощность. Однако, ремонт батареи, в случае выхода из строя одной из секции - очень трудоемкая задача, поэтому на складе запчастей, батарейные блоки бывают L разных видов: шириной в 1 секцию, в 2 секции, ...,в L секций. Такой блок из нескольких секций нельзя разрезать на части, то есть одним блоком можно заменить не более любых L подряд идущих секций. При этом можно менять не только неисправные секции, но и хорошие(стоимость блоков учитывать не будем - работа все-равно выходит дороже). Определите, какое наименьшее число блоков необходимо взять мастеру, чтобы починить всю батарею.

Формат ввода
Первая строка входных данных содержит целое число L(L > 0) - максимальный размер батарейного блока. Во второй строке входных данных записано целое число N(N > 0) - количество секций в заборе. Следующие N строк содержат по одному числу, равному 0 или 1. Число 1 обозначает, что соответствующая секция в батарее нуждается в замене, число 0 - что секция может быть сохранена.

Формат вывода
Программа должна вывести одно целое число - сумму введенных чисел N и M.
Пример
Ввод Вывод
3 2
8
0
0
1
0
1
0
1
0

Показать ответ
Ответ:
BNN11
BNN11
19.04.2023 01:28

Привет всему 12 "А" классу(Реальному).Я знаю, зачем вы тут, и я вам Вы знаете меня, как Anxel09.

var a,b,sum,i : integer;  

begin

 readln(a,b);

 if (a < 0) or (a > 10) then

   while (a < 0) or (a > 10) do begin

       writeln('Число ''a'' не подходит: ');

   readln(a);

   end;

 if (b < 0) or ( b > 10) then

       while (a < 0) or (a > 10) do begin

   

       writeln('Число ''b'' не подходит: ');

   readln(b);

   end;

sum := 1;

   

 for i:= 1 to b do

   sum:= sum * a;

 writeln('Число ''а'' в степени ''b''',' = ', sum );

 

end.

Вот и все!

Объяснение:

0,0(0 оценок)
Ответ:
Kachmaresghg
Kachmaresghg
29.06.2020 23:44

ответ:1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

var

 Chislo, Count, Summa, n: integer;

 

begin

 Summa := 0;

 Count := 0;

 readln(Chislo);

 while Chislo > 0 do

 begin

   n := Chislo mod 10;

   if odd(n) then  

   begin

     Summa := Summa + n;

     inc(Count);

   end;

   Chislo := Chislo div 10;

 end;

 writeln('Сумма  нечетных цифр числа: ', Summa);

 writeln('Кол-во нечетных цифр числа: ', Count);

 writeln('Среднее арифметическое  нечетных цифр: ', Summa / Count);

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота