Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
sabr1nka
11.08.2022 16:21 •
Информатика
40 элементов массива найти сумму отрицательных элементов кратных 5
Показать ответ
Ответ:
skachkov1562
02.10.2020 22:39
For i:=1 to 40 do begin
if (a[i]<0) and (a[i] mod 5 =0) then k:=k+a[i];
end;
writeln;
write('сумма ',k);
0,0
(0 оценок)
Ответ:
юлия1921
02.10.2020 22:39
Var a:array[1..40] of integer;
i,s:integer;
begin
s:=0;
for i:=1 to 40 do begin
a[i]:=random(200)-100;
Writeln('a[',i,']=',a[i]);
if (a[i] mod 5=0) and (a[i]<0) then
s:=s+a[i];
end;
Writeln('Сумма отрицательных элементов кратных 5 равна: ',s);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ClassikStupidMasha
11.10.2020 10:18
Составьте программу,которая рисует 20 отрезков разного цвета)координаты концов отрезков-случайные числа)...
диана2434
07.10.2020 18:17
Решите словесные уравнения....
ZakuroElric
28.08.2022 21:57
Подскажите новые виды интернет -мошенничеств...
valeryanka97
03.05.2022 18:01
Значение арифметического выражения: 4∙254 – 54 + 14 записали в системе счисления с основанием 5. какова сумма цифр содержащихся в этой записи? ответ укажите в десятичной системе....
Beauty52
03.05.2022 18:01
35 . составить блок - схему. : определить среднее арифметическое последовательности чисел a[1], a[2], … a[n]. числа n, a[1], a[2], … a[n] вводятся с клавиатуры....
VladMirnyi
17.11.2022 02:08
Нужно небольшое сочинение про Пикачу и учителя английского . на русском прикольное желательно . заранее...
scvdnl
06.05.2020 08:55
Какие вещества следует выбрать, чтобы получить гидроксид хрома(II)? Необходимо взять :Хлорид хрома (II) и воду Водород и оксид хрома (II) Воду и хром Хлорид хрома (\(II\0)и гидроксид...
Anna678901
06.05.2020 08:55
с этим упражнением по английскому Задание: Fill in the gaps below with the correct form of (not) have to, must, (not) need or should. 1 A: I m going to Florence next week so I to...
kolya0125
01.09.2022 07:59
Чему равен центральный угол если соответствующие ему выписаны угол равен 75,4...
zulaykho001
01.09.2022 07:59
Найти площадь криволинейной трапеции, изображённой на рисунке....
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
if (a[i]<0) and (a[i] mod 5 =0) then k:=k+a[i];
end;
writeln;
write('сумма ',k);
i,s:integer;
begin
s:=0;
for i:=1 to 40 do begin
a[i]:=random(200)-100;
Writeln('a[',i,']=',a[i]);
if (a[i] mod 5=0) and (a[i]<0) then
s:=s+a[i];
end;
Writeln('Сумма отрицательных элементов кратных 5 равна: ',s);
end.