В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ivanvolkov2001
ivanvolkov2001
12.12.2022 13:49 •  Информатика

Составьте программу подсчета общего количества слогов "не", "не" во введенной с клавиатуры строке s. пример ввода: не стыдно не знать - стыдно не учиться.

Показать ответ
Ответ:
Юма123
Юма123
09.10.2020 05:34
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018Внимание! Если программа не работает, обновите версию!

begin

 ReadlnString.MatchValues('[Нн]е').Count.Println

end.

0,0(0 оценок)
Ответ:
marmeoladikp07wow
marmeoladikp07wow
09.10.2020 05:34

var s:string;

i,k:integer;

begin

write ('Введите строку: ');

readln (s);

for i:=1 to length(s)-1 do

if ((s[i]='н') or (s[i] = 'Н')) and ((s[i+1] = 'е') or (s[i+1] = 'Е')) then k:=k+1;

write ('Количество слогов не равно: ',k)

end.


Составьте программу подсчета общего количества слогов не, не во введенной с клавиатуры строке s.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота