Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
loloshka566
27.07.2021 08:53 •
Информатика
Составить программу возведения натурального числа в квадрат, используя следующую закономерность: i2 =1 2 2=1+3 з2 =1 + 3 + 5 42=1+3+5+7 п2 = 1 + 3 + 5 + 7 + 9 + . . + 2 п - 1 программа pascal
Показать ответ
Ответ:
viktorvipp0aa6w
25.08.2020 09:19
Всё до безобразия просто:
var n:integer; nn:real;
begin
write('Введи число: ');
readln(n);
for var i:=1 to n do nn:=nn+(2*i-1);
writeln(n,'^2=',nn);
end.
0,0
(0 оценок)
Ответ:
Vika1568393hhhu
25.08.2020 09:19
Function MySQR(n : Integer) : Integer;
Begin
If n>1 then MySQR:=n+MySQR(n-2) else MySQR:=1;
end;
Var a : Integer;
Begin
Readln(a);
Writeln(MySQR(a*2-1));
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ShahTV
03.09.2021 01:10
Составить блок-схему к покупка билета в театр...
ИэнШоу
12.01.2021 20:51
Напишите программу,которая вычисляет площадь прямоугольника по двум его сторонам....
АНДрЕЙ12277777
14.06.2021 10:39
Найти площадь аквариума в форме куба со стороной N (крышки нет)? Найти площадь кольца, заключенного между двумя окружностями с общим центром и радиусами R1 и R2 (R1 R2)....
black93
26.05.2021 05:34
Составить программу вычисления суммы: 1/(1*3) +1/(2*4)+1/(3*5)+…...
30kotenok04
17.07.2020 05:04
Имеются три лампочки.каждая лампочка имеет 3 цвета,сколько всего комбинаций цветов можно составить из этих лампочек?...
ангелина618
26.05.2021 09:07
Надо: 2¹⁸ бит - перевести в мб 2¹⁶ байт - перевести в терабайты(тб)...
АлинаКравченко
08.09.2022 08:37
6.нужно написать программу в с++. определить класс «студент». сведения о студенте состоят из его фамилии, оценок по сессии, номера курса и кода группы, в которой он учится....
deryabina92
10.05.2021 01:25
Нормы «Монтажа электроустановочных изделий»...
emilsalimov
21.10.2020 05:58
Я просто зарабатываю робаксыИ вот такой вопрос.. ...
zka20zka20
26.03.2023 23:24
Поставьте и объясните постановку знаков запятых: Милым казалось всё и леса и речушки - всякие Пехорки и Вертушинки и стога сена в пустынных вечерних полях одинокие освещенные...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var n:integer; nn:real;
begin
write('Введи число: ');
readln(n);
for var i:=1 to n do nn:=nn+(2*i-1);
writeln(n,'^2=',nn);
end.
Begin
If n>1 then MySQR:=n+MySQR(n-2) else MySQR:=1;
end;
Var a : Integer;
Begin
Readln(a);
Writeln(MySQR(a*2-1));
end.