В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

6.нужно написать программу в с++. определить класс «студент». сведения о студенте состоят из его фамилии, оценок по сессии, номера курса и кода группы, в которой он учится. предусмотреть возможность вывода фамилий и номеров групп для студентов, имеющих оценки 4 и 5; обеспечить вывод информации о студентах группы, код которой вводится с клавиатуры. если таких студентов нет, вывести соответствующее сообщение. (максимальная оценка «хорошо»).

Показать ответ
Ответ:
GoshaCat2005
GoshaCat2005
20.09.2022 02:50

<!DOCTYPE html>

<html lang="en">

<head>

   <meta charset="UTF-8">

   <title>Table</title>

</head>

<body>

<table border="1">

   <tr>

       <td rowspan="3">day</td>

       <td colspan="3">seminar</td>

   </tr>

   <tr>

       <td colspan="2">schedule</td>

       <td rowspan="2">topic</td>

   </tr>

   <tr>

       <td>begin</td>

       <td>end</td>

   </tr>

   <tr>

       <td>monday</td>

       <td>8</td>

       <td>5</td>

       <td>introduction to xml</td>

   </tr>

   <tr>

       <td rowspan="3">tuesday</td>

       <td>8</td>

       <td>11</td>

       <td>xpath</td>

   </tr>

   <tr>

       <td>11</td>

       <td>2</td>

       <td rowspan="2">xsl</td>

   </tr>

   <tr>

       <td>2</td>

       <td>5</td>

   </tr>

   <tr>

       <td>w</td>

       <td>8</td>

       <td>12</td>

       <td>xsl</td>

   </tr>

</table>

</body>

</html>

0,0(0 оценок)
Ответ:
AbraevAidar
AbraevAidar
01.06.2022 04:32

Відповідь:

#include <iostream>

#include <cstdlib>

#include <time.h>

using namespace std;

void randArray(int *Array, int size){

for(int i = 0; i < size; i++){

 Array[i] = rand() % 10 + 1;

}

}

void printArray(int *Array, int size){

for(int i = 0; i < size; i++){

 cout << Array[i] << " ";

}

}

int sumelements(int *Array, int size){

int S = 0;

for(int i = 0; i < size; i++){

 S += Array[i];

}

return S;

}

int main(){

srand(time(NULL));

setlocale(LC_ALL , "Rus");

int size;

cout << "Введите кол-во елементов массива: ";

cin >> size;

if(size < 0){

 cout << "Количество не может быть меньше 0" << endl;

}

int *Array = new int[size];

randArray(Array,size);

printArray(Array,size);

cout << "\nСумма всех елементов массива = " << sumelements(Array,size) << endl;

delete [] Array;

return 0;

}

Пояснення:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота