В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Рома3108
Рома3108
28.05.2021 14:27 •  Информатика

Составить программу тремя Среди чисел 1, 4, 9, 16, 25, … найти первое число, большее n (n – вводится с клавиатуры).

Показать ответ
Ответ:
dank02
dank02
30.12.2020 17:59

Python – багатоцільова мова програмування, яка дозволяє писати код, що добре читається. Відносний лаконізм мови Python дозволяє створити програму, яка буде набагато коротше свого аналога, написаного на іншій мові.

Python - багатоплатформова мова програмування. Це означає, що програми на Python можна запускати в різних операційних системах без будь-яких змін.

Ще однією перевагою Python є його стандартна бібліотека, яка встановлюється разом з Python і містить готові інструменти для роботи з операційною системою, веб-сторінками, базами даних, різними форматами даних, для побудови графічного інтерфейсу програм тощо.

Програми, написані на мові програмування Python, можуть бути як невеликими скриптами, так і складними системами.

Python абсолютно безкоштовний.

Объяснение:

0,0(0 оценок)
Ответ:
ГульнараС
ГульнараС
25.03.2020 09:31

day=0

        p=N

        v=1

        поки p>0

        пц

                p=p-v

                v=v*2

                day= day+1

        кц

  Програма матиме вигляд:

         #include <iostream>

        using namespace std;

        int main(int argc, char** argv)  

        {

            int N, day, p, v;

            cin>>N;

            day=0;

            p=N;

            v=1;

            while (p>0)

            {

                p=p-v;

                v=v*2;

                day++;

             }

            cout<<day;

            return 0;

        }

Таблиця виконання алгоритму

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота