В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
AlexandraBobkova
AlexandraBobkova
05.12.2021 02:10 •  Информатика

Написать программу на c++ для решения следующей : в данной

последовательности расположить сначала все отрицательные, затем положительные

элементы, а нулевые элементы расположить в конце последовательности.​

Показать ответ
Ответ:
rndmymail
rndmymail
10.10.2020 10:20

#include <iostream>

using namespace std;

int main() {

int n;

cin>>n;

int arr[n], k=0;

for (int i=0; i<n; ++i) {cin>>arr[i]; if (arr[i]==0) ++k;}

for (int i=0; i<n-1; ++i) {

 for (int j=0; j<n-i-1; ++j) {

  if (arr[j]>arr[j+1]) {

   int temp;

   temp=arr[j];

   arr[j]=arr[j+1];

   arr[j+1]=temp;

     }

 }

}

if (k>0) {

 int m;

 for (m=0; m<n; ++m) if (arr[m]==0) break;

 for (int i=m; i<n-k; ++i) arr[i]=arr[i+k];

 for (int i=n-k; i<n; ++i) arr[i]=0;

}

for (int i=0; i<n; ++i) cout<<arr[i]<<" ";

return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота