В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
anaradocina
anaradocina
09.08.2022 07:23 •  Информатика

Программирование в delphi 7 написать программу, которая вычисляет силу тока по формуле u/((r1*r2)/(r1+r2)) где u, r1 и r2 пользователем.

Показать ответ
Ответ:
megamerezhnikova
megamerezhnikova
30.06.2020 20:01
Первый вариант: если десятичный логарифм от (2x+3).

Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Нельзя вычислить логарифм от нуля!')
else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
     else WriteLn('f(',x,') = ',Ln(2*x+3)*4/(Tan(3*x)*Ln(10)))
End.

Второй вариант: если логарифм по основанию (2x+3) от 4.

Var X:real;
Begin
Write('x = ');ReadLn(x);
if x<=-1.5 then WriteLn('Ошибка: Основание логарифма должно быть больше нуля!')
else if x = 0 then WriteLn('Ошибка: На ноль делить нельзя!')
     else WriteLn('f(',x,') = ',Ln(4)/(Tan(3*x)*Ln(2*x+3)))
End.
0,0(0 оценок)
Ответ:
verastepanova5
verastepanova5
13.05.2020 16:13
Заполнение с клавиатуры:

Var
   A:array[1..10000] of integer;
   i,n:integer;
   S:real;
Begin
Write('n = ');ReadLn(n);
Write('Введите a1..a',n,': ');
S:=0;
For i:= 1 to N do
    Begin
    Read(A[i]);
    if (A[i] mod 4 = 0) then S:=S+A[i];
    End;
WriteLn('S = ',S);
End.

Заполнение случайными числами:

Var
   A:array[1..10000] of integer;
   i,n:integer;
   S:real;
Begin
Randomize;
Write('n = ');
ReadLn(n);
Write('a1..a',n,': ');
S:=0;
For i:= 1 to N do
    Begin
    A[i]:=random(2*N+1)-N;
    Write(A[i],' ');
    if (A[i] mod 4 = 0) then S:=S+A[i];
    End;
WriteLn;
WriteLn('S = ',S);
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота