Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
araydaribayaray
05.04.2023 01:22 •
Информатика
Нужно написать программу на с++ мы вводим массив из букв, а программа должна их отсортировать по алфавиту
Показать ответ
Ответ:
Kosmen21
08.10.2020 05:55
#include <iostream>
#include <string>
using namespace std;
int main()
{
string S;
cin >> S;
int Mass[52];
for (int i = 0; i < 52; i++)
{
Mass[i] = 0;
}
for (int i = 0; i < S.length(); i++)
{
char c = S[i];
if (c >= 'a'&&c <= 'z')
{
Mass[(int)(c-'a')*2]++;
} else if (c >= 'A'&&c <= 'Z'){
Mass[(int)(c-'A')*2+1]++;
}
}
for (int i = 0; i < 52; i++)
{
for (int j = 0; j < Mass[i]; j++)
{
cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
}
}
return 0;
}
Пример работы программы:
0,0
(0 оценок)
Популярные вопросы: Информатика
Rock2015
21.04.2020 04:00
Перевести целые десятичные числа 9,17,243(эти числа в десятичной сис-ме счисления) в двоичную, восьмеричную и !...
hatira801
11.04.2023 21:57
Статья набранная на компьютере,содержит 16 станиц,на каждой странице 32 строки,в каждой строке 25 символов.определите информационный объем статьи в одной из кодировок unicode,в...
nikgali
26.08.2021 06:50
Все 5-буквенные слова, составленные из букв и, к, р, а, записаны в особом, не алфавитном порядке. вот начало списка: 1. 2. 3. 4. 5. …. укажите номер слова акири....
KaiBennet
25.08.2021 17:02
Какие действия можно настроить для объектов на слайдах в программе PowerPoint?...
Cookiemi2017
13.01.2023 10:33
Построить таблицу истинности ...
Vika556965
09.09.2021 02:29
Синформатикой, алгоритм кумир ...
пахан50
21.03.2023 06:08
нужна . 1. сколько объёмом 700 мбайт потребуется для размещения информации, полность занимающей жесткий диск емкостью 140 гбайт? 2. скорость передачи данных через некоторое...
МамкаДраконов
09.04.2020 03:44
Ваня работает на пк с разрешением экрана 1920 x 1080 пикселей, глубиной цвета 32 бита и частотой обновления экрана 60 гц. верно ли, что при таком режиме работы объем данных,...
rederemin2006
20.03.2022 19:37
При сушке грибы теряют 85% своей массы.сколько надо взять свежих грибов чтобы получить 48 кг сушенных?...
120954943921
20.03.2022 19:37
№1. написать одну из возможных формул для общего члена ряда. доказать непосредственно сходимость ряда и найти сумму ряда. вычислить r5. 2+4/5+8/25+16/125+...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <string>
using namespace std;
int main()
{
string S;
cin >> S;
int Mass[52];
for (int i = 0; i < 52; i++)
{
Mass[i] = 0;
}
for (int i = 0; i < S.length(); i++)
{
char c = S[i];
if (c >= 'a'&&c <= 'z')
{
Mass[(int)(c-'a')*2]++;
} else if (c >= 'A'&&c <= 'Z'){
Mass[(int)(c-'A')*2+1]++;
}
}
for (int i = 0; i < 52; i++)
{
for (int j = 0; j < Mass[i]; j++)
{
cout << (i % 2 == 0?(char)(i/2+'a'):(char)(i/2+'A'));
}
}
return 0;
}
Пример работы программы: