В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
пандос3
пандос3
20.10.2021 20:44 •  Информатика

Посчитайте для массива из N целых чисел, сколько элементов в нем останутся стоять на своих местах после сортировки массива.

Формат входных данных
В первой строке входных данных вводится натуральное число N, не превосходящее 100.

В следующей строке вводятся N целых чисел, по модулю не превосходящих 109.

Формат выходных данных
Выведите единственное число - ответ на задачу.

входные данные выходные данные
3
-1 10 5
1
5
-8 -52 -62 -61 -76
0
c++

Показать ответ
Ответ:
девочка245
девочка245
26.04.2022 15:37
Если Вашу программу исправить, это так будет выглядеть:
var a,b,c,p:real;
begin
writeln('введите размеры треугольника a,b,c');
read(a,b,c);
p:=a+b+c;
if (a=b) and (a=c)then
begin writeln('треугольник равносторонний');
writeln('периметр треугольника',p);
end
else writeln ('треугольник не равносторонний');
end.

А если написать самостоятельно, я бы сделал так:
var
  a,b,c:real;
begin
  Write('Введите размеры треугольника a,b,c: '); Read(a,b,c);
  if (a=b) and (a=c) then
    Writeln('Треугольник равносторонний с периметром ',3*a)
  else Writeln ('Треугольник не равносторонний')
end.
0,0(0 оценок)
Ответ:
kvaki257989
kvaki257989
18.05.2022 16:57

Вот, нашел на одном из сайтов: #include <iostream>

#include <conio.h>

#include <cstdlib>

#include <ctime>

using namespace std;

int main (){

   srand(time(0));

   int n, one, two, co=0, ol, k=0, var, sum1=0, sum2=0;

   bool kto=true;

   cout << "Privet davaii sigraem v kosti.\nPobedit tot u kogo suma 3 broskov budet bolshe\n\n";

   while (k<3)

   {

       cout << "\n1 - Brositj kubik\n2 - Vijti\nViberi variant: ";

       cin >> var;

       if (var==1)

       {

           for (int j=0; j<=1; j++)

               {

                   one=1+(rand()%6);

                   two=1+(rand()%6);

                   cout << "\n";

                   if (kto) cout << "\tTvoi kubiki\n";

                   if (!kto) cout << "\tMoi kubiki\n";

                   cout << "\n";

                   for (int i=1; i<=5; i++)

                   {

                           if (i==1) n=1;

                           else if (i==2 && one==1) n=2;

                           else if (i==2 && one==3 || i==2 && one==2) n=3;

                           else if (i==2 && one==4 || i==2 && one==5 || i==2 && one==6) n=4;

                           else if (i==3 && one==3 || i==3 && one==1 || i==3 && one==5) n=5;

                           else if (i==3 && one==2 || i==3 && one==4) n=2;

                           else if (i==3 && one==6) n=4;

                           else if (i==4 && one==1) n=2;

                           else if (i==4 && one==3 || i==4 && one==2) n=6;

                           else if (i==4 && one==4 || i==4 && one==5 || i==4 && one==6) n=4;

                           else if (i==5) n=7;

                       switch (n){

                           case 1:

                           cout << (char)201 << (char)205  << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)187;

                           break;

                           case 2:

                           cout << (char)186 << "       " << (char)186;

                           break;

                           case 3:

                           cout << (char)186 << " o     " << (char)186;

                           break;

                           case 4:

                           cout << (char)186 << " o   o " << (char)186;

                           break;

                           case 5:

                           cout << (char)186 << "   o   " << (char)186;

                           break;

                           case 6:

                           cout << (char)186 << "     o " << (char)186;

                           break;

                           case 7:

                           cout << (char)200 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)205 << (char)188;

                           break;

                       }

                       if (co%2==0) {

                           cout << "\t";

                           i--;

                           ol=one;

                           one=two;}

                       else {

                           cout << endl;

                           one=ol; }

                   co++;

                   }

                   if (kto){

                       sum1=sum1+one+two;

                       kto=false;

                       continue;

                   }

                   if(!kto){

                       sum2=sum2+one+two;

                       kto=true;

                   }

               }

           }

           else if (var==2) return 0;

           else {

               cout << "\n!!! Viberi variant 1 ili 2 !!!\n";

               continue;}

               k++;

   }

   cout << "\nTvoj rezultat = " << sum1 << endl << "Moj rezultat = " << sum2 << endl;

   if (sum1>sum2)

       cout << "\n\tTi pobedil ;)";

   else cout << "\n\tTi proigral :(";

   getch ();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота