В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
paul1905
paul1905
04.06.2022 18:10 •  Информатика

Напишите программу,в которой вводятся четыре числа ( длины четырёх отрезков ). выведите "да" если из отрезков можно составить прямоугольник инче выведите "нет"

Показать ответ
Ответ:
missisleos
missisleos
27.05.2020 22:54

program ugol;

var a,b,c,f:integer;

begin

writeln('Введите шширину');

readln(a);

readln(b);

writeln('Введите длину');

readln(c);

readln(f);

if (a<>b) or(c<>f)then

writeln('Нет')

else

if (a=b)and(c=f) then

writeln('Да');

end.

(Исправленая версия)

ps(затупил подумал что квадрат это прямоугольник)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота