Напишите программу на вход которой подается с клавиатуры два натуральных числа и которая выводит 1 если первое делится на второе и 0 в противном случае. Без системы If и на Питоне
Абак - счётные доски для вычислений в Древней Греции, Древнем Риме, Древнем Китае и т.д.
Арифмометр - настольная или портативная механическая вычислительная машина.
Перфокарта - носитель информации. Тонкий картон с отверстиями или без них в определённых местах.
Транзистор - полупроводниковое устройство, которое используется для усиления, генерации и преобразования электрических сигналов. Транзисторы заменили вакуумные лампы в большинстве электронных устройств, свершив революцию в создании интегральных схем и компьютеров.
ЭНИАК – первая электронная вычислительная машина.
Бэббидж Чарлз - изобретатель первой аналитической вычислительной машины.
Лавлейс Ада - написала первые программы для аналитической вычислительной машины Беббиджа.
Лейбниц - предложил двоичную систему счисления, автор первой механической счётной машины производившей сложение, вычитание, умножение и деление чисел.
Возняк Стив - один из основателей компании Apple. Разработал первый массовый домашний компьютер и первый массовый персональный компьютер.
Холлерит Герман - создатель электрической статистической табулирующей системы (оборудования для работы с перфокартами).
Непер Джон - изобретатель логарифмов, для их вычисления он предложил устройство под названием «палочки Непера».
Шиккард Вильгельм - придумал «Считающие часы», первый арифмометр, умевший выполнять четыре арифметических действия.
Паскаль Блез - автор первой механической счётной машины, выполнявшей сложение и вычитание чисел. (Паскаль - один из наиболее известных языков программирования.)
Лебедева Сергей - под его руководством была создана МЭСМ (малая электронная счётная машина).
ЯП: С++
#include <iostream>
int main() {
const int N = 5;
int arr[N][N] = {1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 22, 23, 24, 25}; // создаем и заполняем двумерный массив 5x5
for (int i = 0; i < N; i++) // выводим на экран 2-мерный массив;
{
for (int j = 0; j < N; j++)
{
std::cout << arr[i][j] << "\t";
}
std::cout << std::endl;
}
std::cout << "Result #1: ";
for (int i = 0; i < N; i++) // вывод в консоль главной диагонали
{
std::cout << arr[i][i] << "\t";
}
std::cout << "\nResult #2: ";
for (int i = 0; i < N; i++) // вывод в консоль побочной диагонали
{
std::cout << arr[i][N - 1 - i] << "\t";
}
return 0;
}
Объяснение:
Смотри картинку
Объяснение:
Крестик - начало слова, стрелка - конец.
Абак - счётные доски для вычислений в Древней Греции, Древнем Риме, Древнем Китае и т.д.
Арифмометр - настольная или портативная механическая вычислительная машина.
Перфокарта - носитель информации. Тонкий картон с отверстиями или без них в определённых местах.
Транзистор - полупроводниковое устройство, которое используется для усиления, генерации и преобразования электрических сигналов. Транзисторы заменили вакуумные лампы в большинстве электронных устройств, свершив революцию в создании интегральных схем и компьютеров.
ЭНИАК – первая электронная вычислительная машина.
Бэббидж Чарлз - изобретатель первой аналитической вычислительной машины.
Лавлейс Ада - написала первые программы для аналитической вычислительной машины Беббиджа.
Лейбниц - предложил двоичную систему счисления, автор первой механической счётной машины производившей сложение, вычитание, умножение и деление чисел.
Возняк Стив - один из основателей компании Apple. Разработал первый массовый домашний компьютер и первый массовый персональный компьютер.
Холлерит Герман - создатель электрической статистической табулирующей системы (оборудования для работы с перфокартами).
Непер Джон - изобретатель логарифмов, для их вычисления он предложил устройство под названием «палочки Непера».
Шиккард Вильгельм - придумал «Считающие часы», первый арифмометр, умевший выполнять четыре арифметических действия.
Паскаль Блез - автор первой механической счётной машины, выполнявшей сложение и вычитание чисел. (Паскаль - один из наиболее известных языков программирования.)
Лебедева Сергей - под его руководством была создана МЭСМ (малая электронная счётная машина).