В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Напишите легкую программу на паскале . напишите программу которая в последовательности нат. чисел определяет сумму чисел оканчивающихся на 5. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется число оканчивающейся на 5. количество чисел не превышает 100. введённые числе по модулю не превышают 300. программа должна вывести одно число: сумму чисел оканчивающихся на 5. входные данные 3 15 25 24 выходные данные 40

Показать ответ
Ответ:
didisa0282
didisa0282
07.10.2020 12:57
Program suma;
Var a:array [1..100] of integer;
    k, i, sum:integer;
begin
  write('Введите число: ');
  read(k);
  for i:=1 to k do read(a[i]);
  for i:=1 to k do
    if a[i] mod 10 = 5 then
      sum:=sum + a[i];
 
  write('Сумма равна: ', sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота