В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
lukycuk
lukycuk
01.05.2021 07:49 •  Информатика

Написать программу на языке С (массивы)
В классе 32 ученика, рост которых от 147 до 168 см. Написать программу, которая определила бы номер самого высокого ученика и его рост

Показать ответ
Ответ:
никто273
никто273
15.10.2020 12:52

//Братишка, я тебе С++ принёс

#include <iostream>

/*

#include<cstdlib>

#include<ctime>

#include<cmath>*/

using namespace std;

/*

void fill(int arr[32]){

   srand(time(NULL));

   for(int i = 0;i<32;i++){

       arr[i] = rand()%22 + 147;

   }

}*/

int main()

{

   int students[32];

   //fill(students);

   for(int i = 0;i<32;i++){

       cin>>students[i];

   }

   int max_index = students[0];

   for(int i = 0;i<32;i++){

       if(students[i]>max_index){

           max_index=i;

       }

       //Не обязательно

       else{

           continue;

       }

   }

   cout<<"Рост:"<<students[max_index]<<endl;

   cout<<"Номер:"<<max_index+1;

   return 0;

}

Объяснение:

Код в комментариях нужен для автоматизации заполнения(чтобы не придумывать 32 числа)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота