В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
200NaStYa002
200NaStYa002
30.05.2021 19:58 •  Информатика

Написать программу, которая вычисляет значение выражения 10⋅sinx+|x4−x5|. Формат входных данных
Входной файл содержит число x. Считать, что вводимые значения x принадлежат области определения выражения.

Формат выходных данных
В выходной файл выведите ответ на поставленную задачу не менее чем с 4 знаками после десятичной точки.

Примеры:
Вход
1
Выход
8.4147

Показать ответ
Ответ:
Relax111111
Relax111111
26.04.2021 12:13

Код C#:

double x;

           Console.Write("x = ");

           x = Convert.ToInt32(Console.ReadLine());

           x = 10 * Math.Sin(x) + Math.Abs(x*4-x*5);

           Console.WriteLine("Конечный результат: x = {0:0.#####}", x);

           Console.ReadKey();

Код Pascal:

Var

x:real;

Begin

Readln(x);

x := 10* Sin(x)+ abs(x*4-x*5);

write('x = ', x);

end.

Объяснение:


Написать программу, которая вычисляет значение выражения 10⋅sinx+|x4−x5|. Формат входных данных Вход
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота