В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
doggibou
doggibou
07.12.2021 16:29 •  Информатика

Написать программу, которая считывает текст из файла и выводит на экран предложения, содержащие цифры.

Показать ответ
Ответ:
Mary240106
Mary240106
28.05.2020 20:32

Программа:

program files;

var f: text;

   c: string;

begin

 

 assign(f, 'path/to/file.txt');

 reset(f);

 

 while not eof(f)

 do begin

      readln(f,c);

      if(c.Contains('1') or c.Contains('2')

           or c.Contains('3') or c.Contains('4')

             or c.Contains('5') or c.Contains('6')

               or c.Contains('7') or c.Contains('8')

                 or c.Contains('9'))

      then writeln(c);

 end;

 

 close(f);

 

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота