В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
rm819189gmail
rm819189gmail
22.08.2022 13:01 •  Информатика

1) Объем массива 30. Заполняем массив случайными числами от 100 до 500. 2) Вектор {хі}, і=1,…20 вычислите количество компонентов, лежащих в заданном интервале [0,1].
3) а1…аn даны целых цифры. Найти: min(a2,a4,…) + max( a1,a3…).
4) В массиве целых чисел найдите сумму элементов, разделенных как на 3, так и на 6.

написать программу на языке Си. ​

Показать ответ
Ответ:
statarincev2019
statarincev2019
03.02.2023 23:29

#include <iostream>

using namespace std;

int** CreateArr(int rows, int cols)

{

int** arr = new int* [rows];

for (int i = 0; i < rows; i++) arr[i] = new int[cols];

return arr;

}

void FillArr(int** arr, int rows, int cols)

{

for (int i = 0; i < rows; i++) for (int j = 0; j < cols; j++) arr[i][j] = -10 + rand() % 20;

}

void PrintArr(int** arr, int rows, int cols)

{

cout << endl << endl;

for (int i = 0; i < rows; i++)

{

 int min{ -1 };

 cout << "Строка #" << i << ": ";

 for (int j = 0; j < cols; j++)

 {

  cout << '\t' << arr[i][j];

  if (arr[i][j] >= 0 && (arr[i][j] < arr[min / 10][min % 10] || min == -1)) min = (i * 10) + j;

 }

 cout << '\t';

 if (min != -1) cout << "Минимальный положительный элемент в этой строке: " << arr[min / 10][min % 10] << " под индексом [" << min % 10 << ']' << endl;

 else cout << "Положительных элементов нет" << endl;

}

cout << endl << endl;

}

void DeleteArr(int** arr, int rows)

{

for (int i = 0; i < rows; i++) delete arr[i];

delete[] arr;

}

int main()

{

srand(time(NULL));

setlocale(0, "");

int n{}, m{};

cin >> n >> m;

int** a = CreateArr(n, m);

FillArr(a, n, m);

PrintArr(a, n, m);

DeleteArr(a, n);

return 0;

}

0,0(0 оценок)
Ответ:
РенаКОСЫРЕВА
РенаКОСЫРЕВА
22.08.2022 13:26

#include <iostream>

using namespace std;

int main() {

setlocale(LC_ALL, "");

int N = 10;

int max = -9999999;

int sum = 0;

int choise = 0;

int arr[N] = {0};

cout << "Введите 10 значений: ";

for(int i = 0; i<N; ++i) {

cin >> arr[i];

}

cout << "Введите действие (1 - +, 2 - макс. значение, 3 - колво отр. значений)";

cin >> choise;

if(choise==1) {

for(int i = 0; i<N; ++i) {

sum+=arr[i];

}

cout << endl << "Сумма: " << sum;

}

if(choise==2) {

for(int i = 0; i<N; ++i) {

if(arr[i]>max) {

max = arr[i];

}

}

 cout << endl << "Макс. знач: " << max;

}

if(choise==3) {

 for(int i = 0; i<N; ++i) {

   if(arr[i]<0) {

     ++sum;

   }

 }

 cout << "Колво отр. знач: " << sum;

}

 if(choise!=1&&choise!=2&&choise!=3) {

   cout << "Введите корректное значение.";

 }

 return 0;

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота