В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
АНooop
АНooop
17.12.2021 19:50 •  Информатика

Напишите программу для решения задачи : найти сумму отрицательных элементов массива , состоящего из 15 чисел , сформированного случайными числами из диапазона от -20 до 20 (включительно). Полную программу В Паскале (если можно ,то на компе в Паскале с выводом , фото . У меня ноут не поддерживает программу)

Показать ответ
Ответ:
gubkaBob216
gubkaBob216
08.12.2020 06:10

var

       a: array [1..15] of Integer;

       i, sum: Integer;

       

begin

       Randomize;

       sum := 0;

       

       for i := 1 to 15 do

               a[i] := Random (41) - 21;

       

       for i := 1 to 15 do

               if a[i] < 0 then

                       sum := sum + a[i];

               

       Write (sum)

end.        

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота