В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alkhodzhaevaka
alkhodzhaevaka
19.09.2020 13:31 •  Информатика

1.Написать программу вычисления стоимости покупки с учетом скидки. Скидка в 3% предоставляется в том случае, если сумма покупки больше 500 руб., в 5% - если сумма больше 1000 руб. 2.Написать программу, которая бы по введенному номеру единицы измерения (1 — килограмм, 2 — миллиграмм, 3 — грамм, 4 — тонна, 5 — центнер) и массе М выдавала соответствующее значение массы в килограммах.
c++

Показать ответ
Ответ:
geneu
geneu
24.07.2021 18:37

Простейшее задание

Объяснение:

#include <iostream>

#include <functional>

#include <string>

#include <vector>

 

struct converter

{

  std::function<double(double)> function;

  std::string to;

};

 

int main()

{

  std::vector<converter> table =

  {

     {[](double d) { return d; }, "kg"},

     {[](double d) { return d / 1000 / 1000; }, "mg"},

     {[](double d) { return d / 1000; }, "g"},

     {[](double d) { return d * 100; }, "cnt" },

     {[](double d) { return d * 1000; }, "tones" }

  };

  int ind = 0;

  std::cin >> ind;

  ind -= 1;

  if (ind >= 0 && ind < table.size())

  {

     int m = 0;

     std::cin >> m;

     const converter& current = table[ind];

     std::cout << "Result of converting " << m << " " << current.to << " is " << current.function(m) << " kg" << std::endl;

  }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота