В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
milton555
milton555
17.01.2020 11:16 •  Информатика

Здравствуйте нужна Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 6. Программа получает на вход количество чисел в последовательности, а затем сами числа. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число — минимальное число, кратное 6 (в тетради письменно)

Показать ответ
Ответ:
ainashsharipov
ainashsharipov
25.01.2021 19:14

Объяснение:

program prog;

var  

x,i,n,tmp:integer;

arr:array [1..1000] of integer;

begin

Writeln('Enter n: ');

readln(n);

x:=30000;

Writeln('Enter numbers: ');

for i:=1 to n do readln(arr[i]);

for i:=1 to n do

begin

tmp:=arr[i] mod 6;

if (tmp=0) and (arr[i]<x) then x:=arr[i];

end;

writeln(x);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота