Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
masha2450
02.02.2023 13:42 •
Информатика
Заполнить линейный массив из 10 элементов случайными числами. вычислить среднее арифметическое всех его элементов.pascal abc
Показать ответ
Ответ:
gfyfhh
08.10.2020 21:10
Var
a: array [1..10] of integer;
i, k: byte;
sum: real;
begin
randomize;
sum := 0;
k := 0;
writeln(' *** Исходный массив ***');
for i := 1 to 10 do
begin
a[i] := random(50);
sum := sum + a[i];
k := k + 1;
write(a[i], ' ');
end;
writeln(#13+'Среднее арифметическое = ', (sum/k):0:2);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
polinafaber
05.11.2022 09:19
Составить программу для ввода с клавиатуры в массив 12 целых чисел в столбец и вывода чисел в строку в обратном порядке через точку с запятой...
роза266
05.11.2022 09:19
Какие из чисел записаны некорректно? 1) 12453(8) 2) 1212(10) 3) 1212(2) 4) 53684(7) 5) 1836(6) 6) clxxii 7) vcii...
Абдусатор
05.11.2022 09:19
Цикл з передумовою можуть виконуватися більше ніж один раз...
nika7912
13.12.2020 16:42
Вывести на экран все числа от -10 до 10, затем модули этих чисел...
mikalis
07.11.2021 01:15
Задание 3: сообщение состоит из 10 страниц, на каждой странице написано 305 символов. Определите, сколько различных символов содержится в используемом алфавите, если...
Govnomer228
22.03.2020 00:05
Ввбирите верное имя ячейки в электронной таблице п...
addj1404
20.03.2021 21:37
Какие горячие клавиши испоьзуются для инструмента «Рука»? в скетчап 1) Shift 2) Shift+колесо мыши 3) колесо мыши 4)контрол+левая кнопка мыши 5) контрол+колесо мыши...
alexey2030
28.06.2020 16:06
Что может быть утренней, полевой, электронной, голубиной?...
nastyavix
28.06.2020 16:06
Автомобиль подъехал к перекрестку со светофором, когда на светофоре горел красный свет. после этого загорелся желтый свет. какое количество информации при загорании...
vehea78347
29.07.2022 09:43
Какая из команд записана правильно? 1. if (x=0) аnd (a 0) then begin b:=0;c:=x else b:=x; end;2. if (x=0) and (a 0) then begin b:=0;c:=x; end; else b:=x;3. if (x=0)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
a: array [1..10] of integer;
i, k: byte;
sum: real;
begin
randomize;
sum := 0;
k := 0;
writeln(' *** Исходный массив ***');
for i := 1 to 10 do
begin
a[i] := random(50);
sum := sum + a[i];
k := k + 1;
write(a[i], ' ');
end;
writeln(#13+'Среднее арифметическое = ', (sum/k):0:2);
end.