В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
janaljubche
janaljubche
11.05.2021 15:27 •  Информатика

Задано четырехзначное целое число. Составьте программу удвоения этого числа, если сумма его цифр
является четным числом, и уменьшения числа в три
раза, если сумма цифр нечетное число.

Показать ответ
Ответ:
бульбулядор
бульбулядор
28.05.2020 08:30
ответ:

Задание 1.

int a,b;

scanf("%i", &a);

scanf("%i", &b);

if (a<b)

  for(int i=a; i<=b; i++)

     printf("x = ", x , ";    y = ", ((x3+1)/(x-3)+x) );

Задание 2.

int sum;

sum = 0;

for(int i=1; i<=115; i+=6)

  sum+=i;

printf(sum);

Задание 3.

int a,b, n;

n = 0;

scanf("%i", &a);

scanf("%i", &b);

if (a<b)

  for(int i=a; i<=b; i++)

     if (i%11 == 0) n++;

if (a>b)

  for(int i=b; i<=a; i++)

     if (i%11 == 0) n++;

printf(n);

На C ничего никогда не писал, поэтому может чё-то не так, но по идее как-то так...

0,0(0 оценок)
Ответ:
voskoboynikova1
voskoboynikova1
16.04.2020 23:59

84

Пошаговое объяснение:

крайние тролли обнимутся всего один раз, развернутся и уйдут на свой конец улицы, больше никого не встретив.

вторые с краю тролли обнимутся первый раз, развернутся, встретят крайнего тролля, обнимутся с ним, развернутся, опять встретятся-обнимутся, и, развернувшись уйдут на конец улицы больше никого не встретив (крайний тролль то уже ушел...) итого 3 обнимания.

Продолжая эту цепочку получаем

1 3 5 7 9 11 12    11 9 7 5 3 1

отличается только первый тролль из семерки, поскольку он в результате уйдет не на свой конец улицы, а на противоположный...

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота