Задача №112228. Простые числа Напишите программу, которая вводит натуральные числа a и b и выводит все простые числа в диапазоне от a до b .
Входные данные
Входная строка содержит два натуральных числа, a и b . Гарантируется, что a ≤ b .
Выходные данные
Программа должна вывести в одной строке через пробел все простые числа на отрезке [ a , b ] . Если таких чисел нет, программа должна вывести 0.
в
#include <iostream>
#include <cmath>
#include <vector>
using namespace std;
void show_vector(vector <unsigned int> a)
{
for (unsigned int i = 0; i < a.size() - 1; i++)
cout << a[i] << " ";
cout << a.back() << endl;
}
bool f_prostoe(unsigned int x)
{
bool prostoe = true;
for(unsigned int i = 2; i <= int(sqrt(x)); i++)
{
if (x % i == 0)
{
prostoe = false;
break;
}
}
return prostoe;
}
int main()
{
bool pustoi = true;
vector <unsigned int> chisla = {0};
cout << "Введите диапазон, вначале min, затем max." << endl;
cout << "min = ";
unsigned int x;
cin >> x;
cout <<"max = ";
unsigned int y;
cin >> y;
for(x = x; x <= y; x++)
{
if(f_prostoe(x))
{
if (pustoi)
{
pustoi = false;
chisla.pop_back();
}
chisla.push_back(x);
}
}
cout << "Простые числа: " << endl;
show_vector(chisla);
return 0;
}
Объяснение:
В коде есть костыли, но он работает.