В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ALBERTALBERT2004
ALBERTALBERT2004
21.01.2023 04:56 •  Информатика

Яничего не понимаю! составьте программу! арифметические действия над числами пронумерованы так: 1 – сложение, 2 – вычитание, 3 – умножение, 4 – деление. дан номер действия n и вещественные числа a, b (b< > 0). выполнить над числами указанное действие и вывести результат. например, n=2, а=0,40, в=1,00. результат: а-в=-0,60. единицы длины пронумерованы так: 1 – дециметр, 2 – километр, 3 – метр, 4 – миллиметр, 5 – сантиметр. дан номер единицы длины и длина отрезка в этих единицах (вещественное число). найти длину отрезка в метрах.

Показать ответ
Ответ:
птмпль
птмпль
30.09.2020 20:29

{ 1 – дециметр, 2 – километр, 3 – метр, 4 – миллиметр, 5 – сантиметр.}
var
    units: integer;
    value, factor: real;

begin
    write('Введите значение - '); readln(value);
    write('Введите единицу измерения - '); readln(units);
    case units of
        1: factor := 0.1;
        2: factor := 1000;
        3: factor := 1;
        4: factor := 0.001;
        5: factor := 0.01;
    else
        factor := 1;
    end;
    
    writeln(value * factor, ' м');
end.

0,0(0 оценок)
Ответ:
dashka1035
dashka1035
30.09.2020 20:29

var

  d:integer;

  a,b:real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  write('Введите номер операции '); readln(d);

  case d of

    1: writeln(a, ' + ', b, ' = ', a + b);

    2: writeln(a, ' - ', b, ' = ', a - b);

    3: writeln(a, ' * ', b, ' = ', a * b);

    4: begin

        if b <> 0 then

          writeln(a, ' / ', b, ' = ', a / b)

       else

          writeln('делить на 0 нельзя');

     end;

    else

       writeln('Неизвестная операция');

  end;

end.

   

 

 

//вторая программа

 

var

  d:integer;

  a:real;

begin

  write('Длина отрезка = '); readln(a);

  write('Введите код единицы измерения '); readln(d);

  case d of

    1: writeln('Длина отрезка ', a / 10, ' метр(а, ов)');

    2: writeln('Длина отрезка ', a * 1000, ' метр(а, ов)');

    3: writeln('Длина отрезка ', a, ' метр(а, ов)');

    4: writeln('Длина отрезка ', a / 1000, ' метр(а, ов)');

    5: writeln('Длина отрезка ', a / 100, ' метр(а, ов)');

    else

       writeln('Неизвестная единица длины');

  end;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота