В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Nikalusha
Nikalusha
05.08.2021 04:40 •  Информатика

Y=tgx при х изменяется от 0 до 10 написать программу так чтобы она решала с использованием оператора цикла

Показать ответ
Ответ:
мем23
мем23
07.09.2020 21:16
Const a=0; b=10;
var x,y,h:real; n,i:integer;
begin
h:=1;
n:=round((b-a)/h);
x:=a-h;
for i:=0 to n do
 begin
 x:=x+h;
 y:=sin(x)/cos(x);
 writeln(x:4:1,'  ',y:6:3);
 end;
end.

Результат:
 0.0   0.000
 1.0   1.557
 2.0  -2.185
 3.0  -0.143
 4.0   1.158
 5.0  -3.381
 6.0  -0.291
 7.0   0.871
 8.0  -6.800
 9.0  -0.452
10.0   0.648
0,0(0 оценок)
Ответ:
daha0061
daha0061
07.09.2020 21:16
Function tg(a:real):real;
begin
tg:=sin(a)/cos(a);
end;
var
y:real; x:integer;
begin
for x:=0 to 10 do begin
y:=tg(x);
writeln('Y=',y);
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота