Впаскаль написать программу вывода на экран числа x, полученного следующим образом: из трехзначного числа вычли его последнюю цифру, результат разделили на 10, а к частному слева прибавили первую цифру числа x.
Var a, b, c, d, x1, x2 : real; \\ задание переменных действительных чисел.
begin write('a = '); readln(a); \\запрос у пользователя первого коэффициента write('b = '); readln(b); \\запрос у пользователя второго коэффициента write('c = '); readln(c); \\запрос у пользователя третьего коэффициента d := b*b - 4*a*c; \\ расчет дискриминанта if d=0 then \\ветка для решения при нулевом дискриминанте begin x1 := b / (2 * a) writeln (x1:3:3); end \\ окончание при нулевом дискриминанте else if d>0 then \\ ветка для решения при положительном дискриминанте begin x1 := (- b + sqrt(d) / (2 * a); \\ первый корень x2 := (- b - sqrt(d) / (2 * a); \\ второй корень writeln (x1:3:3, ' ', x2:3:3); \\ вывод ответа end else \\ ветка решения для отрицательного дискриминанта writeln ('Нет действительных корней'); end.
Всё таки есть сомнение нужна сумма нечётных элементов массива или сумма элементов массива с нечётными индексами?
В данной прграмме подсчитывается сумма нечётных элементов массива
Если же нужно второе то строку отмеченную {*} следует заменить на
if (i mod 2)>0 then s:=s+a[i];
Program massiv;
Uses Crt;
var a:array[1..10] of integer;
i,sum,ch:integer;
begin
clrscr;
write('Введите число:' );
readln(ch);
write('Введите элементы массива:');
sum:=0;
for i:=1 to 10 do
begin
readln(a[i]);
if (a[i] mod 2)>0 then s:=s+a[i]; {*}
end;
writeln; write('Исходный массив: ');
for i:=1 to 10 do
begin
write(a[i]);
write(' ' );
end;
writeln; writeln;
write('Сумма нечётных элементов массива: ',sum)
writeln; writeln;
write('Номера элементов которые больше числа ',ch,' : ' );
for i:=1 to 10 do
if (a[i]>ch) then
begin
write(i:2);
write(' ' );
end;
writeln; writeln;
write('Положительные числа которые кратны числу ',ch,' : ' );
for i:=1 to 10 do
if (a[i]>0) and (a[i] mod ch=0) then
begin
write(a[i]);
write(' ' );
end;
readkey;
end.
begin
write('a = '); readln(a); \\запрос у пользователя первого коэффициента
write('b = '); readln(b); \\запрос у пользователя второго коэффициента
write('c = '); readln(c); \\запрос у пользователя третьего коэффициента
d := b*b - 4*a*c; \\ расчет дискриминанта
if d=0 then \\ветка для решения при нулевом дискриминанте
begin
x1 := b / (2 * a)
writeln (x1:3:3);
end \\ окончание при нулевом дискриминанте
else
if d>0 then \\ ветка для решения при положительном дискриминанте
begin
x1 := (- b + sqrt(d) / (2 * a); \\ первый корень
x2 := (- b - sqrt(d) / (2 * a); \\ второй корень
writeln (x1:3:3, ' ', x2:3:3); \\ вывод ответа
end
else \\ ветка решения для отрицательного дискриминанта
writeln ('Нет действительных корней');
end.