В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Lerochka1998
Lerochka1998
02.08.2020 13:43 •  Информатика

Вобщем, нужно используя функции mod и div составить программу по нахождению суммы трехзначных чисел, у которых первая и последняя цифры имеют одинаковое значение. и написать отдельную программу в которой нужно посчитать кол-во этих чисел

Показать ответ
Ответ:
vladikn2016
vladikn2016
24.12.2021 17:21

55:5=11

365:11≈33(34) берём "34", чтобы перехлестнуть 365.

Так как 11-ый член является замыкающим (перехлёстывающим 365), тогда смотрим по ближайшим:

34*10=340 (340+34=374) - подходит, но это не максимум!

365 mod 10= 36, а это значит, что последующий член будет больше 365, а именно 395.

В задании сказано, что d должно быть максимальным, а "34" - это допустимое, но не максимально число, удовлетворяющее условию, даже минимальное (по результату).

Проверка:

34*11=374, значит, когда на экране выведется s:=340, n:=50, то, зайдя по следующему циклу, получится, что s:= 374, n:=55. На следующий цикл программа не пойдёт.

ответ: d=34. 

0,0(0 оценок)
Ответ:
неумно
неумно
11.01.2023 17:41
Const e=0.001;
var x,xn,h,an,s,f,y:real; n,k,i:integer;
begin
n:=10;
h:=(1-0.1)/(n-1);
x:=0.1-h;
for i:=1 to n do
 begin
 x:=x+h; an:=1;
 xn:=1; f:=1;
 k:=0;  s:=1;
 while an>e do
  begin
  xn:=xn*x*x;
  k:=k+1;
  f:=f*k;
  an:=(2*k+1)*xn/f;
  s:=s+an;
  end;
 y:=(1+2*x*x)*exp(x*x);
 writeln('x = ',x:4:1,'  s = ',s:6:4,'  y = ',y:6:4);
 end;
end.

Результат:
x = 0.1  s = 1.0303  y = 1.0303
x = 0.2  s = 1.1241  y = 1.1241
x = 0.3  s = 1.2911  y = 1.2911
x = 0.4  s = 1.5490  y = 1.5490
x = 0.5  s = 1.9260  y = 1.9260
x = 0.6  s = 2.4653  y = 2.4653
x = 0.7  s = 3.2320  y = 3.2320
x = 0.8  s = 4.3240  y = 4.3240
x = 0.9  s = 5.8894  y = 5.8895
x = 1.0  s = 8.1548  y = 8.1548
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота