В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
VLev147741
VLev147741
18.04.2021 13:37 •  Информатика

Здравствуйте решить задачу. Напишите программу, которая на вход получает координаты двух клеток шахматной доски и выводит соощение о том, являются ли эти клетки одного цвета.
Формат ввода:
c2
e4
Формат вывода:
Клетки одинакового цвета
Основное решение есть, но как преобразовать буквы в числа
d= int(input())
a= int(input())
b= int(input())
c= int(input())
if (a+b+c+d) % 2 == 0:
print('клетки одинакового цвета')

Показать ответ
Ответ:
Levix322
Levix322
10.08.2021 11:21

Жобалаудың барысын басқаруды жақсарту мақсатында әрбір кезең нақтыланады, яғни кезеңдерге бөлінеді.

Автоматтандырылған жүйені құрудың 4 кезеңі-Жұмыс сипаты, оның нәтижесі немесе орындаушылардың мамандануы бойынша анықталатын АЖ құру сатысының бір бөлігі.

АЖ құру кезеңдерінің мазмұны ГОСТ 34.601-90 1-қосымшасында регламенттелген.

"АС-қа қойылатын талаптарды қалыптастыру" 1-ші сатысында "объектіні тексеру және АС құру қажеттілігінің негіздемесі" 1-ші кезеңінде объект және оның қызметінің түрлері туралы деректер жинауды жүргізеді. Объектінің және оның құрамдас бөліктерінің жұмыс істеу сапасын бағалайды. Автоматтандыру құралдарының көмегімен шешуге болатын мәселелер мен міндеттерді анықтайды. Жүйені құрудың орындылығын бағалаудың техникалық-экономикалық, әлеуметтік және басқа да түрлерін береді.

"АС-қа пайдаланушылардың талаптарын қалыптастыру" 2-ші кезеңінде АС-қа қойылатын талаптарды қалыптастыру үшін бастапқы деректерді дайындайды, пайдаланушылардың талаптарын қалыптастырады және ресімдейді. Автоматтандыру объектісінің сипаттамасы, жүйені әзірлеуге, іске қосуға және пайдалануға рұқсат етілген шығындар, күтілетін нәтиже, жүйені құру және жұмыс істеу шарттары сияқты құжаттарды дайындайды .

3-ші кезеңде" орындалған жұмыс туралы есепті және жүйені (тактикалық-техникалық тапсырма — ТТТ) әзірлеуге өтінімді жасау " 1-ші кезеңде орындалған жұмыстар туралы есепті және ТТТ әзірлеуге өтінімді немесе мазмұны бойынша ұқсас басқа құжатты ресімдейді.

"АС тұжырымдамасын әзірлеу" 2-ші сатысында "объектіні зерделеу" 1-ші кезеңінде автоматтандыру объектісін егжей-тегжейлі зерделейді.

"Қажетті ғылыми-зерттеу жұмыстарын жүргізу" (ҒЗЖ) 2-кезеңінде пайдаланушылардың барлық талаптарын іске асыру мүмкіндігін бағалау және жолдарды іздестіруді орындайды, ҒЗЖ бойынша есептерді ресімдейді және бекітеді.

"АС тұжырымдамасының нұсқаларын әзірлеу және пайдаланушының талаптарын қанағаттандыратын АС тұжырымдамасының нұсқасын таңдау "3-кезеңінде АС тұжырымдамасының, оларды іске асыру жоспарлары мен ресурстарының баламалы нұсқаларын әзірлеуді, артықшылықтары мен кемшіліктерін бағалауды жүргізеді және бірнеше әзірленген оңтайлы нұсқадан таңдайды. Жүйені қабылдау тәртібі мен шарттарын, оның тиімділігін айқындайды.

Объяснение:

0,0(0 оценок)
Ответ:
mrpetrov289
mrpetrov289
23.04.2022 00:23

Часть программы. Решение задач

1. Найдите ошибку в программе:

program ;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

2. Найдите ошибку в программе:

program Prim 2 1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f ); p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

3. Найдите ошибку в программе:

program Prim_2_1;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

4. Найдите ошибку в программе:

program Prim_2_1;

var a,b:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

5. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

6. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

writeln('p=',p);

readln

end.

7. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c+d+f;

writeln('p=',p);

readln

end.

8. Следующий алгоритм в результате выполнения программы находит:

program Prim_2_3;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p:=a+b+c;

writeln('p=',p);

readln

end

9. Найдите ошибку в программе:

program Prim_2_1;

var a,b,c,d,f,p:integer;

begin writeln('Введите 5 численных значений:');

readln(a,b,c,d,f );

p=:a+b+c+d+f;

writeln('p=',p);

readln

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота