В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Прайм231
Прайм231
09.05.2020 19:48 •  Информатика

В среде программирования ABC Pascal напишите программу шифрования с использованием метода замен

Показать ответ
Ответ:
ilonazin03
ilonazin03
07.09.2022 06:41

Парк «Феофанія»

«Феофанія» - парк-пам'ятник садово-паркового мистецтва та садово-парковий комплекс розташований на території Голосіївського району, який створено в 1972 році.

Заповідник розташований в південній частині Голосіївського району. Головною прикрасою парку вважають ланцюжок із п’яти озер, їх називають палладінські озера. На території «Феофанії» розташований гідрологічний пам'ятник природи місцевого значення та два водних джерела, багато дерев, кущів та ліан. Зберіглося багато дерев віком від 100 до 300 років і більше. У парку були зареєстровані 9 червонокнижних видів комах.

Парк «Кіото»

Парк був заснований у 1972 році , він знаходиться на Лісовому масиві. Всі деталі та символіка були запозичені із паркової культури Японії.

В центрі «Кіото» розташований сад каменів. З рослин можна побачити вікові сосни, японський клен. У вересні 2011 році була висаджена алея сакур. Дерева висаджені в два ряди вздовж пішохідних доріжок з внутрішньої сторони. В парку є дзен-сад — гравієвий сад в японському стилі з сухим озером, посеред якого стоять два камені, з'єднані містком. Поряд знаходиться альтанка та водоспад і сухий струмок. В озері живуть червоні рибки.

Объяснение:

0,0(0 оценок)
Ответ:
Nemiroffdenisa
Nemiroffdenisa
24.05.2021 17:43
Romanf romanf отличник 2013-01-10t16: 13: 22+00: 00 1. подумать над алгоритмом 2. вот сам алгоритм: а. спросить у пользователя значения б. расчитать ответ в. выдать ответ на экран 3. написать код в паскале 4. исправить ошибки компиляции 5. протестировать, вводить разные числа 6. обнаружила, что если вводить числа наугад ответ получается отрицательным иногда 7. вставить код проверки введенных пользователем значений 8. убрать ошибки компиляции 9. протестировать 10. готово а вот и сама программа: program aerobus; uses crt; const totalplace = 160; var businessplaces, economyplaces: integer; businessprice, economyprice: real; totalcharge: real; a,b: integer; correctinput: boolean; begin clrscr; businessplaces: =totalplace div 4; economyplaces: = totalplace - businessplaces; writeln('business places count: ', businessplaces); writeln('economy places count: ', economyplaces); correctinput: =false; while not correctinput do begin write('please input business class ticket price: '); readln(businessprice); if(businessprice> 0) then begin correctinput: =true; end else begin writeln('the price should be a positive number, please try again'); end; end; economyprice: =businessprice/2; writeln('economy ticket price is: ', economyprice: 0: 2); correctinput: =false; while not correctinput do begin write('how many business tickets are left? : '); readln(a); if(a> =0) and (a< =businessplaces)then correctinput: =true; if(a< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(a> businessplaces) then begin writeln('please input a number which is less or equal to the tolal business place count, please try again'); end; end; correctinput: =false; while not correctinput do begin write('how many economy tickets are left? : '); readln(b); if(b> =0) and (b< =economyplaces)then correctinput: =true; if(b< 0) then begin writeln('please input a positive number or 0, please try again'); end; if(b> economyplaces) then begin writeln('please input a number which is less or equal to the tolal economy place count, please try again'); end; end; totalcharge: =(businessplaces-a)*businessprice; totalcharge: =totalcharge+(economyplaces-b)*economyprice; writeln('the total charge is: ', totalcharge: 0: 2); writeln; writeln('press enter to exit'); readln; end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота