В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
magakhass
magakhass
21.03.2023 14:09 •  Информатика

«В»: Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне
[10,100] и сортирует его по возрастанию последней
цифры числа (сначала идут все числа, которые
заканчиваются на 0, потом все, которые
заканчиваются на 1, и т.д.).
Пример:
Массив: 12 10 31 40 55 63 28 87 52 92
Сортировка: 10 40 31 12 52 92 63 55 87 28.
Нужно сделать в Python.​


«В»: Напишите программу, которая заполняет массив из N = 10 элементов случайными числами в диапазоне

Показать ответ
Ответ:
wolk2289
wolk2289
16.09.2020 10:56

k = float(input())

s = float(input())

p= float(input())

i = 0

while k < s:

    i += 1

    k += (k / 100)*p

print(f'Через {i} месяцев! Вы получите сумму {k}')

Объяснение:

Вводим нужные числа.

И так, i = это у нас месяцы, которая по умолчанию равна 0.

while у нас заместо времени, каждая итерация while прибавляет к месяцам 1.

И так - каждый месяц мы увеличиваем наш капитал на p.

k += (k/100)*p - считаем проценты.

Насчёт += - это тоже самое, что написать k = k + (k/100) * p.

Условие цикла, цикл будет работать, пока наш капитал меньше нужной суммы.

Как только капитал становиться больше нужной суммы - while прекращает свою работу. И мы получаем через сколько месяцев наберём нужный капитал.

*f - format

0,0(0 оценок)
Ответ:
Zhanar161
Zhanar161
07.04.2021 08:35

Chat GPT – чат-бот на базі штучного інтелекту, який здатний спілкуватися в режимі реального часу, навіть у вигляді суперечки, а також за лічені секунди виводити помилки в коді та писати сценарії, вірші та текстовий контент. Технологію представила компанія OpenAI, одним із засновників якої був Ілон Маск.

Універсальний бот з'явився у листопаді 2022 року і одразу облетів увесь світ. Його реалізовували за до суперкомп'ютера Azure AI, а як мовну модель використовували технологію від OpenAI – GPT-3,5.

Цікавим був сам процес навчання Chat GPT. Для нього використовували систему зв'язку з людиною та величезний масив тексту, а потім переучували багато разів, використовуючи відповіді самого чат-бота. Таким чином, вдалося досягти ще коректніших результатів генерації. Розробники хотіли зробити його максимально “людським” і простим для взаємодії.

За даними аналітиків Bloomberg чат-бот універсальний. Його можна використовувати не тільки для написання тексту чи віршів, а й для:

проведення фінансового аналізу;

генерація простого коду;

вибудовування прогнозів;

резюм технічних статей;

створення персональних порад;

реалізації етичних відповідей

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота