В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Дарина15746
Дарина15746
22.10.2020 19:37 •  Информатика

Напишите программу в Python, которая получает на вход нижнюю и верхнюю границу диапазона целых чисел соответственно (ввод нажатием на клавишу после каждого числа), а выводит все числа, которые при делении на 15 дают в остатке 11, а при делении на 11 дают в остатке 9.

Показать ответ
Ответ:
mironovvladimir1
mironovvladimir1
19.08.2020 06:15

n_bott = int(input("Least number of interval - "))

n_top = int(input("The largest number of interval - "))

num_list = []

for num in range(n_bott,n_top + 1):

   if ((num % 15 == 11) and (num % 11 == 9)):

       num_list.append(num)

print(*num_list)


Напишите программу в Python, которая получает на вход нижнюю и верхнюю границу диапазона целых чисел
0,0(0 оценок)
Ответ:
caramel1701
caramel1701
19.08.2020 06:15

#Более экономная по памяти версия

lb, rb = map(int, input('Enter lower and upper range borders:\n').split())

cond = lambda item: item % 15 == 11 and item % 11 == 9

[print(item, end='\n') for item in filter(cond, range(lb, rb+1))]

ввод:

100 1000

вывод

251

416

581

746

911

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота