В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
кошачка278
кошачка278
21.09.2020 17:34 •  Информатика

Учебная модель ЭВМ. Написать программу, которая вычисляет количество четных чисел с подпрограммой

Показать ответ
Ответ:
balasanyansilva
balasanyansilva
01.09.2021 20:00

Солнечная система - это система планет, в центре которой находится яркая звезда, источник энергии, тепла и света - Солнце.  

По одной из теорий Солнце образовалось вместе с Солнечной системой около 4,5 миллиардов лет назад в результате взрыва одной или нескольких сверхновых звезд. Изначально Солнечная система представляла собой облако из газа и частиц пыли, которые в движении и под воздействием своей массы образовали диск, в котором возникла новая звезда Солнце и вся наша Солнечная система. В центре Солнечной системы находится Солнце, вокруг которого по орбитам вращаются девять крупных планет. Так как Солнце смещено от центра планетарных орбит, то за цикл оборота вокруг Солнца планеты то приближаются, то отдаляются по своим орбитам.

Различают две группы планет:  

1. планеты земной группы : Планеты земной группы: Меркурий, Венера, Земля и Марс. Эти планеты небольшого размера с каменистой поверхностью, они находятся ближе других к Солнцу.

2. планеты гиганты : Планеты гиганты: Юпитер, Сатурн, Уран и Нептун. Это крупные планеты, состоящие в основном из газа и им характерно наличие колец, состоящих из ледяной пыли и множества скалистых кусков. А вот

Плутон не попадает ни в одну группу, т.к., несмотря на свое нахождение в Солнечной системе, слишком далеко расположен от Солнца и имеет совсем небольшой диаметр, всего 2320 км, что в два раза меньше диаметра Меркурия. Солнце Солнце представляет собой гигантский огненный шар очень высокой температуры, состоящий из из плазмы (ионизированного газа) в составе с водородом и гелием. Диаметр солнца 1,4 млн км, температура на поверхности 5700° C, а в ядре 14 000 000° C. Солнце удалено от Земли на 149,6 млн км и имеет жизненно важное значение для всего растительного и животного мира на Земле.

Планеты Солнечной системы :  

 Меркурий Самая маленькая и самая близкая к Солнцу планета. Меркурий так медленно вращается, что проходя полный круг вокруг солнца, совершает оборот вокруг своей оси всего 1,5 раза, из-за чего солнечные сутки на планете длятся 58 земных суток. Поэтому на ночной половине Меркурия температура опускается до -180° C, а на дневной половине планеты раскаляется до +430° C.

  Венера Самая близкая к Земле планета. Венеру окружает слой очень плотных облаков, вследствии парникового эффекта. Температура поверхности планеты разогрета до +470° C, процент содержания в атмосфере углекислого газа гораздо больше, чем в горных породах, при этом планета расположена совсем недалеко от Солнца, что и приводит к такому эффекту повышения температуры. На Венере постоянно происходят вспышки молний, превышающие по интенсивности на Земле, что, возможно, также связывают с вулканической деятельностью

    Земля Планета Земля обладает атмосферой, которую удерживают силы гравитации, в состав атмосферы входят важные элементы водорода, углерода, которые делают возможным на Земле жизнь. Поверхность Земли состоит на 2/3 из воды, остальная часть это континенты, где и в воде и на суше развивается жизнь. Кислород на Земле, не критическая температура на поверхности планеты и другие свойства дали благоприятную возможность для существования растительного, животного мира и жизни человека на Земле. Спутник Земли: Луна  

   Марс Небольшая планета, которая представляется невооруженным глазом, как красная планета. Наличие на планете образований, напоминающих русла рек, а также следов каньонов и океанов, говорит в пользу теории, что Марс наиболее похож по структуре на планету Земля. До сих пор, ученые подразумевают наличие воды на планете. Также, как и на нашей планете, на Марсе присутствует атмосфера, только содержание в ней кислорода ничтожно мало, всего 0,13%, а давление на поверхности гораздо ниже земногоСпутники Марса: Фобос и Деймос

    Юпитер Самая крупная планета в Солнечной системе, состоящая из газа, слои которого находятся в постоянных вихреобразных движениях. Диаметр Юпитера огромный - 143 000 км (для сравнения: диаметр Земли 13 000км). Не смотря на свои крупные размеры, Юпитер очень быстро вращается вокруг своей оси (за 9ч 50 мин земных суток) из-за чего диаметры на полюсах планеты сжаты, а экватор растянут. Кольца и спутники Юпитера: Европа, Ио, Ганимед, Каллисто

 Сатурн Эта удивительная и красивая планета обладает ярко-выраженными кольцами, которые легко разглядеть в обычный телескоп, а уникальность Сатурна еще и в том, что его плотность ниже средней плотности воды и, если представить, что на поверхности мог бы быть океан, то можно было бы увидеть невероятное зрелище, как его воды легко плескались бы на поверхности планеты Кольца и спутники Сатурна: Титан, Энцелад.

Объяснение:

0,0(0 оценок)
Ответ:
svetaobukhova1
svetaobukhova1
26.09.2020 13:24
Программа, которая использует два массива

var 
c, a: array[1..20] of integer; 
i: integer;
begin 
write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 1 to 20 do   begin   
a[i] := c[20 - i + 1];   
write(a[i], ' '); 
end;  
end.

ИЛИ  Программа не использующая два массива, а просто переворачивающая первый

var 
c: array[1..20] of integer; 
i: integer;
begin  write('Первый массив '); 
for i := 1 to 20 do   begin   
c[i] := i * (-5);   
write(c[i], ' '); 
end; 
writeln; 
write('Преобразованный массив '); 
for i := 20 downto 1 do  write(c[i], ' '); 
end.

Обе программы работают!
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота