В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Niker04
Niker04
01.12.2022 08:53 •  Информатика

Требуется разработать программу, которая получает с клавиатуры координаты точки на плоскости, и определяет, попадает ли точка в залитую оранжевым область (линии в область не входят). написать программу нужно двумя можно в одной программе ввести данные, а потом двумя получить результат): 1) с применением логических операций 2) с вложенных условных операторов. разрешается также применение функций, арифметических операций. ответ - текст программы в документе ms word.

Показать ответ
Ответ:
Zhannochka3110
Zhannochka3110
29.05.2020 09:21

Могу подсказать только 1 вариант:

Объяснение:

Module Module1

   Sub Main()

       Dim x As Single

       Dim y As Single

       Console.WriteLine("Введите координаты точки x ")

       x = Console.ReadLine()

       Console.WriteLine("Введите координаты точки y ")

       y = Console.ReadLine()

       If (x <= 4 And y <= 4 And y >= 4 - x) Or (y <= -4 - x And y >= -4 And x >= -4) Then Console.WriteLine("Точка принадлежит области") Else Console.WriteLine("Точка не принадлежит области")

       Console.ReadKey()

   End Sub

End Module

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота