В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dkrutov03
dkrutov03
18.11.2020 19:11 •  Информатика

Только для ! составить программу, которая позволяет ввести два числа в первой строке, и один из знаков (+, -, *, /) во второй строке. на экран должен быть выведен результат выполнения соответствующего арифметического действия. для ввода знака использовать переменную типа char.

Показать ответ
Ответ:
Spectator10
Spectator10
03.10.2020 06:19
Var 
s: char; 
a, b: real;
begin 
Write('Введите два числа '); 
Readln(a, b); 
Write('Введите действие (+, -, *, /) - '); 
Readln(s); 
case s of    
'+': writeln(a, ' + ', b, ' = ', a + b);   
'-': writeln(a, ' - ', b, ' = ', a - b);   
'*': writeln(a, ' * ', b, ' = ', a * b);   
'/': if (b=0) then writeln('На ноль делить нехорошо - бесконечность получится') else writeln(a, ' / ', b, ' = ', a / b);
End;
end.
0,0(0 оценок)
Ответ:
созданной
созданной
03.10.2020 06:19
Var  Ch : Char;
  a,b : Integer;
Begin
  Readln(a,b);
  Readln(Ch);
  Case Ch of
   '+' : Writeln(a+b);
   '-' : Writeln(a-b);
   '*' : Writeln(a*b);
   '/' : Writeln(a/b);
  end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота