В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SashaWest
SashaWest
15.04.2020 04:18 •  Информатика

Св "паскале"! 1. составьте алгоритм вычисления суммы всех натуральных чисел, не превышающих заданного натурального числа n. проверьте алгоритм трассировкой.(объясните за одно, что такое "трассировка") 2. дано целое число х и натуральное n. составьте алгоритм вычисления х^n. проверьте алгоритм трассировкой.

Показать ответ
Ответ:
misterwotblitz
misterwotblitz
06.07.2020 11:37
1)
var
    i, n, m: integer;

begin
    readln(n);
    for i := 1 to n do
        m := m + i;
    writeln('сумма всех натуральных чисел не превышающих ', n, ' - ', m);
end.

2)
var
    x, n, i, p: integer;

begin
    write('Число: ');
    readln(x);
    write('Степень :> ');
    readln(n);
    p := 1;
    for i := 1 to n do
        p := p * x;
    writeln('Результат: > ', p);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота