Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
ayazhankadyrov24
20.01.2022 16:47 •
Информатика
Создайте и протестируйте программу вычисления расстояния ab между точками с коорднатами (x1,y1) и (x2,y2), которые вводятся с клавиатуры паскаль решение
Показать ответ
Ответ:
Polia111111
08.10.2020 14:26
Program Coords;
var x1,x2,y1,y2,S:real;
begin
write('Введите X1 : '); readln(X1);
write('Введите Y1 : '); readln(Y1);
write('Введите X2 : '); readln(X2);
write('Введите Y2 : '); readln(Y2);
S:=sqrt(sqr(x2-x1)+sqr(y2-y1));
writeln(s);
end.
0,0
(0 оценок)
Ответ:
eliot40
08.10.2020 14:26
Var x1, x2, y1, y2, s: real;
begin
read(x1, y1, x2, y2);
s:=sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1));
write(s:0:3);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
kseniy32
05.03.2020 07:47
До какого числа должно измениться значение счетчика i в фрагменте программы, чтобы А стало равным 120? A:=1; for i:=2 to … do A:=A*i;...
123123258852
28.02.2021 01:12
На числовой прямой даны два отрезка: p = [1, 39] и q = [23, 58]. выберите из предложенных отрезков такой отрезок a, что логическоевыражение( (x p) → ¬ (x q) )→ ¬ (x а)тождественно...
настя7096
28.02.2021 01:12
Тема: одномерные массивы, написать программу использую rite, riteln ; все элементы кратные трем делятся на три, остальные умножаются на 3....
qwidonsky
04.02.2022 05:00
Сор по информатике,хелп...
tchasikova2018
02.12.2022 01:32
Втаблице dat хранятся данные о количестве сделанных учениками (dat[1] сделал первый ученик, dat[2] – второй и т. определите, какое число будет напечатано в результате работы следующей...
ГолубойРо
02.02.2021 06:18
Кдроби со знаменателем 4а^5c^2 дроби: 1) 4а а^3c 2) 5ac^3 a^2c 3) 4a 2ac^2 4) ac^4 0.5ac 5) 5.5ac a^2c 6) -ax a^3c...
AnutaBelova1524
02.02.2021 06:18
Вкаких условиях возникла жизнь на земле...
Лина1990
02.02.2021 06:18
Рассмотрите пары предложений. докажите, что в одних случаях выделенные слова и конструкции являются вводными, а в других — нет. расставьте недостающие знаки препинания. 1)словом...
alina067
02.02.2021 06:18
Около окружности описан правильный четырёхугольник со стороной 6 см и в окружность вписан правильный треугольник .найдите площадь треугольника сейчас прямо...
nick313
02.02.2021 06:18
Причины по которым затрудняет изучение наследственности человека (хотя бы 3 причины)...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var x1,x2,y1,y2,S:real;
begin
write('Введите X1 : '); readln(X1);
write('Введите Y1 : '); readln(Y1);
write('Введите X2 : '); readln(X2);
write('Введите Y2 : '); readln(Y2);
S:=sqrt(sqr(x2-x1)+sqr(y2-y1));
writeln(s);
end.
begin
read(x1, y1, x2, y2);
s:=sqrt((x2-x1)*(x2-x1)+(y2-y1)*(y2-y1));
write(s:0:3);
end.