Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
настя7096
28.02.2021 01:12 •
Информатика
Тема: одномерные массивы, написать программу использую rite, riteln ; все элементы кратные трем делятся на три, остальные умножаются на 3.
Показать ответ
Ответ:
Zaynab2897
02.07.2020 19:16
Const N=...;//указываешь количество элементов массива
var a:array [1..N] of integer;
i:integer;
begin
for i:=1 to N do
readln(a[i]);
for i:=1 to N do begin
if a[i] mod 3 =0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;
writeln(a[i]);
end;
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
olkvochka1707
22.03.2021 23:21
Написать программу на паскале,определяющую является ли матрица магическим квадратом....
polly009090
15.06.2020 22:02
Восстановите взаимосвязь компонентов компьютера ...
Yatoi
28.09.2021 01:08
ПРОГРАММАНЫ ТЕСТІЛЕУ 8 сынып ИНФОРМАТИКА ...
чурка2829
11.11.2021 03:48
Лишайники выделяют в отдельную группу организмов, так как они , состоят из гриба и водоросли требовательны к чистоте окружающей среды медленно растут служат пищей животным...
mschibarova201
11.11.2021 03:48
Восстановите славообразовательные цепочки 1)пыль- опыление 2)...
rahim55
11.11.2021 03:48
Подчеркнуть грамматическую основу. 1) после дождя дорога была скользкой, и идти было трудно. 2) за окном брезжил рассвет и кричали петухи. 3) меня пробирала дрожь и начинало клонить...
Heda0101
11.11.2021 03:48
Три друга витя, коля, петя уехали отдыхать в лагерь, деревню и санаторий и занимались там волейболом,футболом и боксом. известно что: - витя уехал не в лагерь, а коля не в деревню...
okfuh
11.11.2021 03:48
Вставь в предложения имена собственные.вреспублике казахстан есть высокие горы ....
AlbertDavtyan
11.11.2021 03:48
Определение что такое самооценка и...
maksimbrykin2017
11.11.2021 03:48
На стройку за три дня 943 тонны грунта.в первый день 278 тонн,во второй на 94 тонны больше.сколько тонн грунта в третий день?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var a:array [1..N] of integer;
i:integer;
begin
for i:=1 to N do
readln(a[i]);
for i:=1 to N do begin
if a[i] mod 3 =0 then a[i]:=a[i] div 3 else a[i]:=a[i]*3;
writeln(a[i]);
end;
end.