В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
2006veronika34
2006veronika34
29.06.2022 05:55 •  Информатика

Создать программу! тема "организация подпрограмм через функцию" дан параллепипед с измерениями а,b, c. составить программу для нахождения площади полной поверхности, используя подпрограмму нахождения площади прямоугольника.

Показать ответ
Ответ:
mrsdyy
mrsdyy
21.07.2020 12:25
Вычисление производим по формуле
S=2(ab+ac+bc)=2(Sp_{(a,b)}+Sp_{(a,c)}+Sp_{(b,c)}); \ Sp_{(x,y)}=x\cdot y

function Sp(x,y:real):real;
begin
  Sp:=x*y
end;

var
  a,b,c,S:real;
begin
  Write('Введите размеры сторон a,b,c: ');
  Read(a,b,c);
  S:=2*(Sp(a,b)+Sp(a,c)+Sp(b,c));
  Writeln('Площадь поверхности равна ',S)
end.

Тестовое решение:
Введите размеры сторон a,b,c: 2.5 3.15 4
Площадь поверхности равна 60.95
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота