Составьте программу в паскаль, которая запрашивает ввод целых положительных чисел и определяет произведение нечётных из них. признаком конца ввода считать ввод числа -4.
Var a:array[1..1024] of integer; p:longint; i:integer; begin p:=1; repeat i:=i+1; readln(a[i]); if a[i]<0 then begin if a[i]<>-4 then writeln('Vvedite polozhitelnoe chuslo'); end else begin if a[i] mod 2<>0 then p:=p*a[i];end; until a[i]=-4; writeln('Proizvidenie = ',p); end.
p:longint;
i:integer;
begin
p:=1;
repeat
i:=i+1;
readln(a[i]);
if a[i]<0 then begin if a[i]<>-4 then writeln('Vvedite polozhitelnoe chuslo');
end
else
begin
if a[i] mod 2<>0 then p:=p*a[i];end;
until a[i]=-4;
writeln('Proizvidenie = ',p);
end.