В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
sanya1130
sanya1130
14.03.2021 06:49 •  Информатика

Составьте программу сортировки по возрастанию значений трёх переменных: a,d,c.

Показать ответ
Ответ:
varta
varta
04.10.2020 10:21
Var
    a, d, c, t: integer;

begin
    readln(a, d, c);
    if a < d then begin t := a;a := d;d := t; end;
    if a < c then begin t := a;a := c;c := t; end;
    if d < c then begin t := d;d := c;c := t; end;
    writeln(a, ' ', d, ' ', c);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота