В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Макс332211
Макс332211
26.12.2020 05:48 •  Информатика

Составьте программу рисования 15 квадратов синего цвета с общим центром

Показать ответ
Ответ:
димон333777
димон333777
06.07.2021 18:46

1)

var

a: integer;

even,odd: byte;

begin

readln(a);

even := 0;

odd := 0;

while a > 0 do begin

 if (a mod 2) = 0 then

  even := even + 1

 else

  odd := odd + 1;

 a := a div 10;

end;

writeln('even: ', even);

writeln('odd: ', odd);

end.

2)

var

   n, m: longint;

   a: byte;

begin

   readln(n);

   m := 0;

   while n>0 do begin

       a := n mod 10;

       n := n div 10;

       m := m*10 + a;

   end;

   writeln(m);

readln;

end.

3)

var

   a,b,c,i,n: integer;

begin

   write('n = ');

   readln(n);

   a := 0;

   write(a,' ');

   b := 1;

   write(b,' ');

   for i:=3 to n do begin

       write(a+b,' ');

       c := b;

       b := a + b;

       a := c

   end;

readln

end.

Объяснение:


Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
Проверочная работа. 1)ЗадачаНаписать программу, подсчитывающую количество четных и нечетных цифр в ч
0,0(0 оценок)
Ответ:
kursovaalena8
kursovaalena8
17.03.2020 04:21

1) зачем тебе передавать в функцию флоат, а потом это кастовать к даблу, когда можно сразу передавать дабл

2) на кой тебе setlocale в этой задаче

3) почему ты пытаешься считать из консоли 7 аргументов, когда в задаче дается лишь 4

4) много лишних переменных, да еще и разных типов, которые ты пытаешься использовать в одних выражениях

5) Ты вообще понимаешь почему в этой задаче требуется прописать функцию для нахождения площади треугольника? Если да, то почему ты каждый раз вызываешь функцию подсчета площади от одних и тех же трех отрезков, да еще и не образующих треугольник...

#include <iostream>

#include <cmath>

using namespace std;

double heron(double a_, double b_, double c_){

   double p = (a_ + b_ + c_) / 2;

   return sqrt(p * (p - a_) * (p - b_) * (p - c_));

}

void solve() {

   double a, b, c, d;

   cout << "a =\n";

   cin >> a;

   cout << "b =\n";

   cin >> b;

   cout << "c =\n";

   cin >> c;

   cout << "d =\n";

   cin >> d;

   cout << "S = " << heron(a, 1, 2) + heron(b, 2, 2.5) + heron(c, d, 2.5);

}

int main(){

   solve();

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота