Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
alina124561
10.10.2020 00:21 •
Информатика
Составьте программу поиска трехзначных чисел которые при делении на 43 в остатке 41 а при делении на 47 в остатке 43
Показать ответ
Ответ:
Anya18121978
08.07.2020 01:32
А нет таких чисел!
var
i:integer;
begin
for i:=1 to 10000 do // по условиям задачи i:=1 to 999
if (i mod 43 = 41) and (i mod 47 = 43) then
writeln(i);
end.
Результаты вывода:
1030
3051
5072
7093
9114
Так что минимальное число, удовлетворяющее требованиям, 1030, но оно не трехзначное
Вот более продвинутый алгоритм, делающий то же самое:
var
n43:integer;
begin
n43:=127;
repeat
n43:=n43+43;
until (n43 mod 43 = 41) and (n43 mod 47 = 43); //добавить and (n43<1000)
writeln(n43)
end.
Результат вывода:
1030
0,0
(0 оценок)
Популярные вопросы: Информатика
Блейк51
25.07.2021 19:01
Упростить логическую функцию (желательно по действиям, с указанием правил, по которым произошло упрощение), доказать правильность....
kamillaakhmetz
18.07.2020 08:38
задание в файле (сделать в программе куМир стандарт)...
debiltrue
11.09.2022 21:49
Бағдарламау жүйесінің режмін анықтаңыз...
piv1490
19.09.2022 09:06
Программа перекодировала сообщение из Unicode в KOI-8? При этом информационный объем сообщения уменьшился на 500байт. Какое количество символов содержится в сообщении?...
kati1200777
09.12.2020 12:13
с информатикой, алгоритмы...
rasimfanov
15.01.2022 05:35
Составьте описание одной из зон южной америки...
tashbaeva201
15.01.2022 05:35
Стороны одного треугольника равн 7 см, 10см, 8см, а периметр подобного ему треугольника равен 75см. найти стороны второго треугольника....
ervinbek2005
15.01.2022 05:35
Округлите числа до указаного разряда: а) до десятых: 26,397; 3,039; 35,262; 8,132; 299,9999; б) до сотых : 76,343; 22,038; 0,685; 0,00098; 7,008 в)до тысячных: 2,5555;...
Aytgbssh
15.01.2022 05:35
1) как изменяются числа в каждой строке? 981,972,963, 327,324321, как связаны между собой числа первой и второй строки? 2) продолжи каждую строчку ещё на три числа в соответствии...
kkira1
15.01.2022 05:35
Определите какаие из перечисленных превращений являються а)железо из железной руды,б)медный провод из медных болванок,в)щебень из гранита,г)скульптрас из мрамора...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
var
i:integer;
begin
for i:=1 to 10000 do // по условиям задачи i:=1 to 999
if (i mod 43 = 41) and (i mod 47 = 43) then
writeln(i);
end.
Результаты вывода:
1030
3051
5072
7093
9114
Так что минимальное число, удовлетворяющее требованиям, 1030, но оно не трехзначное
Вот более продвинутый алгоритм, делающий то же самое:
var
n43:integer;
begin
n43:=127;
repeat
n43:=n43+43;
until (n43 mod 43 = 41) and (n43 mod 47 = 43); //добавить and (n43<1000)
writeln(n43)
end.
Результат вывода:
1030