В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
666SmEtAnKa666
666SmEtAnKa666
28.11.2021 04:44 •  Информатика

Составьте программу на паскале, чтобы пк запросил имя пользователя и его год рождения, подсчитал возраст человека, в зависимости от возраста разработайте вариант диалога с пользователем (-ещё не учишься? ; -учишься где? ; уже не учишься? )

Показать ответ
Ответ:
sara6yjfhjh9
sara6yjfhjh9
04.10.2020 22:13
Var
a,b,j,v,c:string;
q: integer;

begin
writeln('Напишите своё имя');
readln(a);
writeln('Напишите дату рождения, год целиком');
readln(q);
q:=2016-q;
write(' - Привет,',a,'. ');
if q<7 then begin writeln('Ты уже пошел в детский сад?'); readln (' - ',b);
if (b='Да') or (b='да') then writeln ('Удачи!') else writeln (' - Пойди в Детский сад, там тебя обучат азам жизни. Удачи')  end; else if (7<q) and (q<17) then begin writln (' - Ты пошёл в школу?'); readln (' - ',c); if (c='Да') or (c='да') then begin writeln (' - В какую школу ты пошёл?'); readln (' - ',v); writeln (' - В каком ты классе?'); readln (' - ',j);end;
end.

Так можно продолжать бесконечно
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота