В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
newumnik
newumnik
03.01.2021 01:29 •  Информатика

Напишите программу для решения . велосипедист едет с постоянной скоростью. найдите скорость велосипедиста, если расстояние s он преодолел за t минут. , !

Показать ответ
Ответ:
Almurt
Almurt
30.04.2022 12:06
Const n=20; 
var
  a:array[1..n] of integer;
  i,j,t,x,i1,i2:integer;
begin
  Randomize;
  Writeln('Исходный массив:');
  for i:=1 to n do begin
    a[i]:=Random(21);
    Write(a[i],' ')
  end;
  Writeln;
  for i:=1 to n-1 do
    for j:=1 to n-i do
      if a[j]<a[j+1] then
      begin t:=a[j]; a[j]:=a[j+1]; a[j+1]:=t end;
  Writeln('Отсортированный массив:');
  for i:=1 to n do Write(a[i],' ');
  Writeln;
 write('x = '); readln(x);
 i1:=1; i2:=n;
 repeat
  i:=(i1+i2) div 2;
  if a[i]>x then i1:=(i1+i2) div 2+1;
  if a[i]<x then i2:=(i1+i2) div 2-1;
 until (a[i]=x)or(i1>i2);
 if a[i]=x then 
  begin
  writeln('Искомый(ые) номер(а) элемента(ов):');
  while (i>0)and(a[i]=x) do i:=i-1;
  i:=i+1;
  while (i<=n)and(a[i]=x) do begin write(i,' '); i:=i+1; end;
  end
  else writeln('Элемент не найден');
 writeln;
end.

Пример:
Исходный массив:
15 4 16 3 7 10 3 1 18 6 18 2 7 11 10 16 2 10 7 12 
Отсортированный массив:
18 18 16 16 15 12 11 10 10 10 7 7 7 6 4 3 3 2 2 1 
x = 10
Искомый(ые) номер(а) элемента(ов):
8 9 10 
0,0(0 оценок)
Ответ:
Екатерина13250804
Екатерина13250804
15.09.2022 13:34
Const
   N = 3;
   M = 4;
Type
   Mass = array[1..N,1..M] of integer;
///Функция вычисления среднего арифметического элементов массива
Function Sr(A:Mass):real;
Var
   i,j:integer;
Begin
result:=0;
For i:= 1 to N do
    For j:= 1 to M do
        result:=result+A[i,j];
result:=result/(M*N);
End;

Var
   A:Mass;
   B:array[1..N,1..M-1] of integer;
   i,j,jMax,k:integer;
   S,MaxS:real;
Begin
Randomize;
WriteLn('Исходная матрица:');
For i:= 1 to N do
    Begin
    For j:= 1 to M do
        Begin
        A[i,j]:=random(21)-10;
        Write(A[i,j]:3,' ')
        End;
    WriteLn
    End;
WriteLn('Среднее арифметическое её элементов: ',Sr(A));
WriteLn;
MaxS:=0;
jMax:=1;
For i:= 1 to N do
    MaxS:=MaxS+A[i,1];
For j:= 2 to M do
    Begin
    S:=0;
    For i:= 1 to N do
        S:=S+A[i,j];    
    if S > MaxS then
       Begin
       jMax:=j;
       MaxS:=S;
       End;
    End;
k:=0;
For j:= 1 to M do
    if jMax <> j then
       Begin
       k:=k+1;
       For i:= 1 to N do
           B[i,k]:=A[i,j];
       End;
WriteLn('Новая матрица:');
For i:= 1 to N do
    Begin
    For j:= 1 to M-1 do
        Write(B[i,j]:3,' ');
    WriteLn
    End;
End.

Пример работы программы:

Исходная матрица:
 10   6  10   2
  3   5  -3   8
  8   2   0  -9
Среднее арифметическое её элементов: 3.5

Новая матрица:
  6  10   2
  5  -3   8
  2   0  -9
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота