В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alenadevyataya
alenadevyataya
15.07.2021 10:29 •  Информатика

Составьте программу ,которая заполняет массив а[1..8] случайными целыми числами в диапазоне от 1 до 10 и находит количество элементов с чеоными значениями и произведение элементов с нечетными значениями

Показать ответ
Ответ:
dashkin21
dashkin21
02.10.2020 03:38
Program rand_max;
  const
    size=8;
  var
    main_mas: array [1..size] of integer;
    i,nchet,proizv:integer;
  begin 
        nchet:=0; 
        proizv:=1; 
        randomize; 
        writeln('Исходный массив:'); 
        for i:=1 to size do  begin   
           main_mas[i]:=random(11);   
           write(' ',main_mas[i],' ');   
           if (Odd(main_mas[i])) then      
                begin       
                    inc(nchet);       
                    proizv:=proizv*main_mas[i];     
                end; 
       end; 
       writeln; 
       writeln('Кол-во нечетных: ',nchet); 
       writeln('Произведениче нечетных = ',proizv);  
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота