Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
Ангелинка2007
04.09.2021 20:26 •
Информатика
Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.
Показать ответ
Ответ:
daryatabuewa
03.10.2020 07:49
Var
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
0,0
(0 оценок)
Ответ:
konfetkaa2004
03.10.2020 07:49
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
for var i:=100 to 999 do begin
var d1:=i div 100;
var d2:=(i div 10) mod 10;
var d3:=i mod 10;
if sqr(d1)=d2+d3 then Print(i)
end;
Println
end.
Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497
0,0
(0 оценок)
Популярные вопросы: Информатика
salhk
13.10.2022 18:06
Определи назначение окна устоновки пароля...
nikj12320
26.09.2021 08:12
Задача Моторний човен та швидкісний човен (глісер) рухаються з швидкостями 36км/год та 54 км/год відповідно. Який шлях пройде кожен із човнів за 20Хвилин?Побудувати...
КрохаДи
28.02.2020 12:20
100б. Циклы , только блок схемы...
Wika201720062006
22.04.2023 06:24
Задача D. Найди две единицы Ограничение по времени: 0.5 секундОграничение по памяти: 256 мегабайтПри записи чисел в фибоначчиевой системе счисления в качестве цифр используются...
1StarTrek1
15.02.2020 09:13
Напишите программу для нахождения площади трапеции на с...
Nadin18
13.02.2022 23:16
Що таке алгоритм? Що таке об’єкт? Наведи приклад; Які властивості має об’єкт? В який іб здійснюється керування об’єктами у середовищі Скретч? З якої команди починається...
karahenov98Алекс
13.01.2021 20:47
КроссвордДайте ответ !...
misi2
03.02.2021 12:44
Що стається з об єктом, що після цього змінюється значення? ...
помогите5132
24.02.2020 13:36
От разведчика было получено сообщение: 001010011011101110 В этом сообщении зашифрован пароль - последовательность русских букв. В пароле использовались буквы А, Б, К,...
Ptigran
30.03.2023 03:44
Решить и написать объяснение...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
begin
for var i:=100 to 999 do begin
var d1:=i div 100;
var d2:=(i div 10) mod 10;
var d3:=i mod 10;
if sqr(d1)=d2+d3 then Print(i)
end;
Println
end.
Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497