Составьте программу, которая стронг круговую диаграмму
иллюстрирующую сдачу
каменов группой студентов (10
Во студентов слапи на 4, 15 студентов сдали на 5.35 %
студентов сдали на 6. 10-%
студентов сдали на 7, 10-% студентон сдали на 8, 10 %
студентов сдали на 9 и 10% студентов сдали на 10.0
#include "pch.h"
#include
#include
using namespace std;
double f(double x)
{
double m = -7 * pow(x, 3) - 5.8*x - 4;
return m;
}
int main()
{
double a = -1; double b = 2;
flag1:
double c = 0.5*(a + b);
if (f(c) == 0)
cout << "The result is " << c << endl;
if (f(c)*f(a) < 0)
{
b = c;
goto flag1;
}
if (f(c)*f(b) < 0)
{
a = c;
goto flag1;
}
if (c >= a && c <= b)
cout << "The solution belongs to the interval" << endl;
else
cout << "The solution doesn't belongs to the interval";
return 0;
}
Тут с флагами. Если не нравятся флаги - перестройте под себя.
2) простое. в любой ситуации и при любых условиях мы можем смело утверждать, что 3 больше двух. Истина
3) я спектакль не смотрела, для меня - это ложь. для другого человека - это высказывание может быть истиной. это сложное.
4) простое. значение - истина
5) сложное. в зависимости от того, что будет завтра, будет принимать разные значения - если будет дождь или снег, то Истина, а если не будет снега и дождя, то ложь