В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Viki5776766
Viki5776766
23.09.2022 17:32 •  Информатика

Составьте программу которая содержит функцию нахождения количества разрядов заданного числа не превосходящего 1000000000

Показать ответ
Ответ:
Влад5624
Влад5624
04.10.2020 02:23
Function kr(n:longint):integer;
var
  s:string;
begin
  Str(Abs(n),s);
  kr:=Length(s)
end;

var
  k:longint;
begin
  Write('Введите целое число: '); Read(k);
  Writeln('В этом числе количество разрядов равно ',kr(k))
end.

Пример работы программы
Введите целое число: 1234567
В этом числе количество разрядов равно 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота