В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ArinaStar337
ArinaStar337
16.02.2022 01:46 •  Информатика

Составьте программу, которая позволяет ввести элементы массива а с клавиатуры и выводит на экран количество отрицательных элементов и их индексы. p.s. не надо искать ответ в инете, т.к. там не правильно

Показать ответ
Ответ:
Fulin666
Fulin666
04.10.2020 12:19
// PascalABC.NET 3.2, сборка 1338 от 16.11.2016
begin
  var a:=ReadArrInteger('Введите 10 чисел, нажмите Enter'+#13#10,10);
  var t:=a.Select((x,i)->(x,i+1)).Where(x->x[0]<0);
  Write('Отрицательных- ',t.Count,'; их номера ');
  t.Select(x->x[1]).Println
end.

Пример
Введите 10 чисел, нажмите Enter
 3 14 0 -13 6 -11 -4 0 7 12
Отрицательных- 3; их номера 4 6 7
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота